app-pda/barry: [QA] inherit ltprune.eclass directly
[gentoo.git] / app-pda / barry / barry-0.18.3.ebuild
index 0e72f701fc46170758766ef536ed5eabe1ce57bf..c6d007d92d4b911f14d741b7dde7098ee890144d 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=5
-inherit bash-completion-r1 eutils flag-o-matic gnome2-utils udev
+inherit bash-completion-r1 eutils flag-o-matic gnome2-utils ltprune udev
 
 DESCRIPTION="Sync, backup, program management, and charging for BlackBerry devices"
 HOMEPAGE="http://www.netdirect.ca/software/packages/barry/"
@@ -12,17 +11,16 @@ SRC_URI="mirror://sourceforge/barry/${P}.tar.bz2"
 LICENSE="CC-BY-SA-3.0 GPL-2" #See logo/README for CCPL
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="boost desktop doc gui nls static-libs"
+IUSE="boost doc gui nls static-libs"
 
-RDEPEND=">=dev-cpp/libxmlpp-2.6
-       >=dev-libs/glib-2
+RDEPEND=">=dev-cpp/libxmlpp-2.6:2.6
+       dev-libs/glib:2
        >=dev-libs/libtar-1.2.11-r2
        >=media-libs/libsdl-1.2
-       >=sys-fs/fuse-2.5
+       >=sys-fs/fuse-2.5:=
        sys-libs/zlib
        virtual/libusb:1
        boost? ( >=dev-libs/boost-1.33 )
-       desktop? ( >=net-libs/libgcal-0.9.6 )
        gui? (
                dev-cpp/glibmm:2
                dev-cpp/gtkmm:2.4
@@ -50,7 +48,7 @@ src_configure() {
                $(use_enable static-libs static) \
                $(use_enable boost) \
                $(use_enable gui) \
-               $(use_enable desktop) \
+               --disable-desktop \
                --disable-rpath
 }
 
@@ -87,7 +85,6 @@ src_install() {
        dobashcomp "${S}"/bash/btool "${S}"/bash/bjavaloader
 
        newicon -s scalable "${S}"/logo/${PN}_logo_icon.svg ${PN}.svg
-       use desktop && domenu "${S}"/menu/barrydesktop.desktop
        use gui && domenu "${S}"/menu/barrybackup.desktop
 
        prune_libtool_files
@@ -99,14 +96,6 @@ pkg_preinst() {
 
 pkg_postinst() {
        gnome2_icon_cache_update
-
-       elog "Barry requires you to be a member of the \"usb\" group."
-       ewarn
-       ewarn "Barry and the in-kernel module 'BERRY_CHARGE' are incompatible."
-       ewarn
-       ewarn "Kernel-based USB suspending can discharge your blackberry."
-       ewarn "Use at least kernel 2.6.22 and/or disable CONFIG_USB_SUSPEND."
-       ewarn
 }
 
 pkg_postrm() {