*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-misc / hivex / hivex-1.3.14.ebuild
index dd48bcb9adfa8f272c2fee0de6121e21779420ad..2e226ec0f3966b627fa4e818de5ba32b3d8dd2e3 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-USE_RUBY="ruby21 ruby22 ruby23"
+USE_RUBY="ruby23 ruby24 ruby25"
 RUBY_OPTIONAL=yes
 
-PYTHON_COMPAT=(python2_7 python3_{4,5,6})
+PYTHON_COMPAT=(python2_7 python3_6)
 
 inherit eutils perl-module ruby-ng python-single-r1
 
@@ -16,7 +16,7 @@ SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
 
 LICENSE="LGPL-2.1"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="ocaml readline +perl python test static-libs ruby"
 
 RDEPEND="
@@ -27,7 +27,10 @@ RDEPEND="
                         dev-ml/findlib[ocamlopt]
                         )
        readline? ( sys-libs/readline:0 )
-       perl? ( dev-perl/IO-stringy )
+       perl? (
+               dev-lang/perl:=
+               dev-perl/IO-stringy
+       )
        ruby? ( $(ruby_implementations_depend) )
        python? ( ${PYTHON_DEPS} )
        "