*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / app-i18n / libhangul / libhangul-0.1.0.ebuild
index 50efbefa38203cb9a561dbc8a9994a0ac456be5b..cb63ebcdd7fdedfbfc791aad55afcb06748661ed 100644 (file)
@@ -1,32 +1,36 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI="6"
 
-DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
-HOMEPAGE="https://code.google.com/p/libhangul/"
-SRC_URI="https://libhangul.googlecode.com/files/${P}.tar.gz"
+DESCRIPTION="Library for hangul input method logic, hanja dictionary"
+HOMEPAGE="https://github.com/libhangul/libhangul"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
 
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ppc64 x86"
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="amd64 ppc ppc64 x86"
 IUSE="nls static-libs test"
+RESTRICT="!test? ( test )"
 
-RDEPEND="nls? ( virtual/libintl )"
+RDEPEND="virtual/libiconv
+       nls? ( virtual/libintl )"
 DEPEND="${RDEPEND}
        virtual/pkgconfig
        nls? ( sys-devel/gettext )
        test? ( dev-libs/check )"
 
-DOCS="AUTHORS ChangeLog NEWS README"
-
 src_configure() {
        econf \
                $(use_enable nls) \
                $(use_enable static-libs static)
 }
 
+src_test() {
+       emake -C test check
+}
+
 src_install() {
        default
-       rm -f "${ED}"/usr/lib*/libhangul.la
+       find "${ED}" -name '*.la' -delete || die
 }