app-eselect/eselect-awk: [QA] Fix BadHomepage
[gentoo.git] / app-eselect / eselect-python / eselect-python-99999999.ebuild
index dbfcd6cf0118237088f09c097dbd6ebc8ebf3e2d..4405011868ae1eb646f8ead3b3037c6fad0a992b 100644 (file)
@@ -1,19 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI=5
+EAPI=6
 
 if [[ ${PV} == "99999999" ]] ; then
        inherit autotools git-r3
        EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
 else
-       SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+       SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 fi
 
 DESCRIPTION="Eselect module for management of multiple Python versions"
-HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -24,6 +23,7 @@ RDEPEND=">=app-admin/eselect-1.2.3
        >=dev-lang/python-exec-2.4.2"
 
 src_prepare() {
+       default
        [[ ${PV} == "99999999" ]] && eautoreconf
 }