app-emulation/xen: revbumps; add xsa-156 patches in 4.5 4.5.2-r1, 4.6.0-r2
[gentoo.git] / app-emulation / wine / wine-1.7.35.ebuild
index b403d11adebdcac61212505c9bdbee73beac040a..8f493b046b74446bc041c9de50442e2847cf6a86 100644 (file)
@@ -66,7 +66,7 @@ RESTRICT="test"
 COMMON_DEPEND="
        truetype? ( >=media-libs/freetype-2.0.0[${MULTILIB_USEDEP}] )
        capi? ( net-dialup/capi4k-utils )
-       ncurses? ( >=sys-libs/ncurses-5.2:=[${MULTILIB_USEDEP}] )
+       ncurses? ( >=sys-libs/ncurses-5.2:0=[${MULTILIB_USEDEP}] )
        udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
        fontconfig? ( media-libs/fontconfig:=[${MULTILIB_USEDEP}] )
        gphoto2? ( media-libs/libgphoto2:=[${MULTILIB_USEDEP}] )
@@ -163,10 +163,18 @@ wine_build_environment_check() {
        [[ ${MERGE_TYPE} = "binary" ]] && return 0
 
        # bug #549768
-       if [[ $(gcc-major-version) = 5 ]]; then
-               eerror "You need gcc-4.x to build wine; see https://bugs.gentoo.org/549768"
-               eerror
-               return 1
+       if use abi_x86_64 && [[ $(gcc-major-version) = 5 && $(gcc-minor-version) -le 2 ]]; then
+               einfo "Checking for gcc-5 ms_abi compiler bug ..."
+               $(tc-getCC) -O2 "${FILESDIR}"/pr66838.c -o "${T}"/pr66838 || die
+               # Run in subshell to prevent "Aborted" message
+               if ! ( "${T}"/pr66838 || false ) >/dev/null 2>&1; then
+                       eerror "64-bit wine cannot be built with gcc-5.1 or initial patchset of 5.2.0"
+                       eerror "due to compiler bugs; please re-emerge the latest gcc-5.2.x ebuild,"
+                       eerror "or use gcc-config to select a different compiler version."
+                       eerror "See https://bugs.gentoo.org/549768"
+                       eerror
+                       return 1
+               fi
        fi
 
        if use abi_x86_64 && [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]]; then