dev-python/txaio: add ~x86-linux keyword
[gentoo.git] / app-emacs / slime / slime-2.20.ebuild
index b8a5bdb9d7fa1c6b3e69732a715ffe31811a5a01..d03c14d9dbf8838b81027137e9c92b2bdd9e8f2a 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit elisp eutils
+inherit elisp
 
 DESCRIPTION="SLIME, the Superior Lisp Interaction Mode (Extended)"
 HOMEPAGE="http://common-lisp.net/project/slime/"
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/slime/slime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-2 xref? ( xref.lisp )"
 SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="amd64 ~ppc ~sparc ~x86"
 IUSE="doc xref"
 RESTRICT=test # tests fail to contact sbcl
 
@@ -25,22 +25,27 @@ CLPACKAGE=swank
 CLSYSTEMS=swank
 SITEFILE=70${PN}-gentoo.el
 
+PATCHES=(
+       # Should be fixed in >=app-emacs/slime-2.20
+       "${FILESDIR}/${PN}-2.20-fix-doc-build.patch"
+)
+
 src_prepare() {
+       default
        # Remove xref.lisp (which is non-free) unless USE flag is set
        use xref || rm -f xref.lisp
-       eapply_user
 }
 
 src_compile() {
        elisp-compile *.el || die
        BYTECOMPFLAGS="${BYTECOMPFLAGS} -L contrib -l slime" \
                elisp-compile contrib/*.el lib/*.el || die
-       emake -j1 -C doc slime.info || die "Cannot build info docs"
 
-       #if use doc; then
-       #       VARTEXFONTS="${T}"/fonts \
-       #               emake -j1 -C doc slime.pdf || die "emake doc failed"
-       #fi
+       emake -C doc slime.info || die
+       if use doc ; then
+               VARTEXFONTS="${T}"/fonts \
+                       emake -C doc all
+       fi
 }
 
 src_install() {