*/*: Discontinue Gentoo SuperH port
[gentoo.git] / app-editors / vim / vim-9999.ebuild
index d4037bd79419da12776a48b7c0e0d22ce43c071b..16d2245653a9666493faee6d0ba545d5727e550c 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-VIM_VERSION="8.1"
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+EAPI=7
+VIM_VERSION="8.2"
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby24 ruby25 ruby26"
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
 
 inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils
 
@@ -14,8 +14,8 @@ if [[ ${PV} == 9999* ]] ; then
        EGIT_REPO_URI="https://github.com/vim/vim.git"
 else
        SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
-               https://dev.gentoo.org/~radhermit/vim/vim-8.0.0938-gentoo-patches.tar.bz2"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+               https://dev.gentoo.org/~radhermit/vim/vim-8.2.0210-gentoo-patches.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
 fi
 
 DESCRIPTION="Vim, an improved vi-style text editor"
@@ -23,7 +23,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
 
 SLOT="0"
 LICENSE="vim"
-IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux tcl terminal vim-pager"
+IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
 REQUIRED_USE="
        python? ( ${PYTHON_REQUIRED_USE} )
        vim-pager? ( !minimal )
@@ -47,6 +47,7 @@ RDEPEND="
        racket? ( dev-scheme/racket )
        ruby? ( ${RUBY_DEPS} )
        selinux? ( sys-libs/libselinux )
+       sound? ( media-libs/libcanberra )
        tcl? ( dev-lang/tcl:0= )
        X? ( x11-libs/libXt )
 "
@@ -174,6 +175,7 @@ src_configure() {
                myconf=(
                        --with-features=tiny
                        --disable-nls
+                       --disable-canberra
                        --disable-acl
                        --enable-gui=no
                        --without-x
@@ -192,6 +194,7 @@ src_configure() {
 
                myconf=(
                        --with-features=huge
+                       $(use_enable sound canberra)
                        $(use_enable acl)
                        $(use_enable cscope)
                        $(use_enable gpm)
@@ -200,9 +203,7 @@ src_configure() {
                        $(use_with luajit)
                        $(use_enable nls)
                        $(use_enable perl perlinterp)
-                       $(use_enable python pythoninterp)
                        $(use_enable python python3interp)
-                       $(use_with python python-command $(type -P $(eselect python show --python2)))
                        $(use_with python python3-command $(type -P $(eselect python show --python3)))
                        $(use_enable racket mzschemeinterp)
                        $(use_enable ruby rubyinterp)