*/*: Bump copyright on files touched this year
[gentoo.git] / app-editors / nvi / nvi-1.81.6-r7.ebuild
index 434f2449d10f135559e4535b312570ac55899367..cc7f7301612cedc755d8b6d38ea7bc94a544325f 100644 (file)
@@ -1,18 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
 EAPI=6
 
 inherit autotools db-use flag-o-matic
 
-DESCRIPTION="Vi clone"
+DESCRIPTION="Re-implementation of the classic 4BSD ex/vi"
 HOMEPAGE="https://sites.google.com/a/bostic.com/keithbostic/vi"
 SRC_URI="http://garage.linux.student.kuleuven.be/~skimo/nvi/devel/${P}.tar.bz2"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~x64-macos"
 IUSE="perl tcl unicode"
 
 CDEPEND=">=sys-libs/db-4.2.52_p5:=
@@ -58,9 +57,12 @@ src_configure() {
        use unicode && myconf="${myconf} --enable-widechar"
        use tcl && myconf="${myconf} --enable-tclinterp"
 
-       append-cppflags "-D_PATH_MSGCAT=\"\\\"${EPREFIX%/}/usr/share/vi/catalog/\\\"\""
+       append-cppflags "-D_PATH_MSGCAT=\"\\\"${EPREFIX}/usr/share/vi/catalog/\\\"\""
        append-cppflags -I"$(db_includedir)"
 
+       # Darwin doesn't have stropts.h, bug #619416
+       [[ ${CHOST} == *-darwin* ]] && export vi_cv_sys5_pty=no
+
        pushd dist 2>/dev/null || die
        econf \
                --program-prefix=n \