www-servers/caddy: Version bump to 0.10.4
[gentoo.git] / app-crypt / ophcrack / ophcrack-3.6.0.ebuild
index bf6912108a048b478733ccb7fd8f1ceaffe12bbc..2d78a14dabf4da8151ce09aa923d36910d7d14dd 100644 (file)
@@ -1,8 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI="3"
+EAPI="6"
 inherit eutils
 
 DESCRIPTION="A time-memory-trade-off-cracker"
@@ -12,9 +11,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="qt4 debug +tables"
+IUSE="debug libressl qt4 +tables"
 
-CDEPEND="dev-libs/openssl
+CDEPEND="!libressl? ( dev-libs/openssl:0= )
+                libressl? ( dev-libs/libressl:0= )
                 net-libs/netwib
                 qt4? ( dev-qt/qtgui:4 )"
 DEPEND="app-arch/unzip
@@ -23,6 +23,8 @@ DEPEND="app-arch/unzip
 RDEPEND="tables? ( app-crypt/ophcrack-tables )
                 ${CDEPEND}"
 
+PATCHES="${FILESDIR}/ophcrack-openssl-des.patch"
+
 src_configure() {
 
        local myconf