*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-crypt / libsecret / libsecret-0.18.8.ebuild
index e2192fecdb220d7e9b6f8e85aa94b7cbc7e51905..51c4fb64c3f3fb4e201f4aa125dba7d8428b82a3 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_6 )
 VALA_USE_DEPEND=vapigen
 
 inherit gnome2 multilib-minimal python-any-r1 vala virtualx
@@ -14,11 +14,12 @@ LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
 SLOT="0"
 
 IUSE="+crypt +introspection test +vala"
+RESTRICT="!test? ( test )"
 # Tests fail with USE=-introspection, https://bugs.gentoo.org/655482
 REQUIRED_USE="test? ( introspection )
        vala? ( introspection )"
 
-KEYWORDS="alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd"
+KEYWORDS="alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 sparc x86"
 
 RDEPEND="
        >=dev-libs/glib-2.44:2[${MULTILIB_USEDEP}]