*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-crypt / certbot-nginx / certbot-nginx-9999.ebuild
index bda8ab5ae6d7dbec77ef438c0cac37dbc8e65cc0..b7c737e19b3ca9713f8a81258e6978ec4021fa52 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_6,3_7})
 
 if [[ ${PV} == 9999* ]]; then
        EGIT_REPO_URI="https://github.com/certbot/certbot.git"
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999* ]]; then
        S=${WORKDIR}/${P}/${PN}
 else
        SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~x86"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
        S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
 fi
 
@@ -25,8 +25,8 @@ IUSE=""
 
 CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="${CDEPEND}
-       >=app-crypt/certbot-0.22.0[${PYTHON_USEDEP}]
-       >=app-crypt/acme-0.25.0[${PYTHON_USEDEP}]
+       >=app-crypt/acme-1.0.0[${PYTHON_USEDEP}]
+       >=app-crypt/certbot-1.0.0[${PYTHON_USEDEP}]
        dev-python/mock[${PYTHON_USEDEP}]
        dev-python/pyopenssl[${PYTHON_USEDEP}]
        >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]