*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-crypt / certbot-nginx / certbot-nginx-9999.ebuild
index babe1c82fd63fd06f0314b739866a394b62f07c3..b7c737e19b3ca9713f8a81258e6978ec4021fa52 100644 (file)
@@ -1,17 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI=5
-PYTHON_COMPAT=(python2_7)
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_6,3_7})
 
 if [[ ${PV} == 9999* ]]; then
        EGIT_REPO_URI="https://github.com/certbot/certbot.git"
        inherit git-r3
        S=${WORKDIR}/${P}/${PN}
 else
-       SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-ngin}-${PV}.tar.gz"
-       KEYWORDS="~amd64"
+       SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
        S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
 fi
 
@@ -22,14 +21,14 @@ HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-IUSE="test"
+IUSE=""
 
-CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="${CDEPEND}
-       ~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
-       ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+       >=app-crypt/acme-1.0.0[${PYTHON_USEDEP}]
+       >=app-crypt/certbot-1.0.0[${PYTHON_USEDEP}]
        dev-python/mock[${PYTHON_USEDEP}]
        dev-python/pyopenssl[${PYTHON_USEDEP}]
-       dev-python/pyparsing[${PYTHON_USEDEP}]
+       >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
        dev-python/zope-interface[${PYTHON_USEDEP}]"
 DEPEND="${CDEPEND}"