*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-backup / borgbackup / borgbackup-9999.ebuild
index fdd80a89ecd9163313501def579814d1f3650792..b326c5264e419ff1db835a612ef68b531881ce4c 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1
 
@@ -26,6 +26,7 @@ IUSE="libressl"
 RDEPEND="
        !!app-office/borg
        app-arch/lz4
+       virtual/acl
        dev-python/llfuse[${PYTHON_USEDEP}]
        dev-python/msgpack[${PYTHON_USEDEP}]
        dev-python/pyzmq[${PYTHON_USEDEP}]
@@ -39,8 +40,15 @@ DEPEND="
        ${RDEPEND}
 "
 
+BDEPEND="dev-python/pkgconfig"
+
 python_prepare_all() {
        # allow use of new (renamed) msgpack
        sed -i "s|'msgpack-python.*',||g" setup.py || die
        distutils-r1_python_prepare_all
 }
+
+src_install() {
+       distutils-r1_src_install
+       doman docs/man/*
+}