*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / app-arch / dump / dump-0.4.46-r1.ebuild
index f984ca0ef78bcc911b71cffcb2238fc7c14700ad..04f67e84ac4f6d65250bf5c7943625584e1dc9a9 100644 (file)
@@ -1,11 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit versionator
-
-MY_P="${PN}-$(replace_version_separator 2 b)"
+MY_P="${PN}-$(ver_rs 2 b)"
 S=${WORKDIR}/${MY_P}
 DESCRIPTION="Dump/restore ext2fs backup utilities"
 HOMEPAGE="http://dump.sourceforge.net/"
@@ -13,10 +11,11 @@ SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86"
 # We keep uuid USE flag default dsiabled for this version. Don't forget
 # to default enable it for later versions as this is the upstream default.
 IUSE="bzip2 debug ermt libressl lzo readline selinux sqlite ssl static test uuid zlib"
+RESTRICT="!test? ( test )"
 REQUIRED_USE="
        ermt? ( ssl )
        ssl? ( zlib )
@@ -44,10 +43,14 @@ RDEPEND=">=sys-fs/e2fsprogs-1.27:=
                static? ( sys-libs/ncurses:=[static-libs] )
        )"
 DEPEND="${RDEPEND}
-       virtual/pkgconfig
        virtual/os-headers"
+BDEPEND="
+       virtual/pkgconfig
+"
 
-PATCHES=( "${FILESDIR}"/${P}-openssl11.patch )
+PATCHES=(
+       "${FILESDIR}"/${P}-openssl11.patch
+)
 
 src_configure() {
        local myeconfargs=(