*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-admin / ansible / ansible-9999.ebuild
index 91c2329b31649c12bc18c7e41b730463c2a8a9b0..0e604595dbcad1bf0acd5adc0b096453bb0737d7 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 
 inherit distutils-r1 git-r3 eutils
 
@@ -16,6 +16,7 @@ LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
 IUSE="doc test"
+RESTRICT="test"
 
 RDEPEND="
        dev-python/paramiko[${PYTHON_USEDEP}]
@@ -26,13 +27,18 @@ RDEPEND="
        dev-python/httplib2[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
        dev-python/netaddr[${PYTHON_USEDEP}]
+       dev-python/pexpect[${PYTHON_USEDEP}]
        net-misc/sshpass
        virtual/ssh
 "
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+               >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+       )
        test? (
                ${RDEPEND}
                dev-python/nose[${PYTHON_USEDEP}]
@@ -51,11 +57,6 @@ python_compile_all() {
        fi
 }
 
-python_prepare_all() {
-       rm -fv MANIFEST.in || die
-       distutils-r1_python_prepare_all
-}
-
 python_test() {
        nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
 }