*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-admin / ansible / ansible-9999.ebuild
index 4284a69a020e76f42824550fb0d7b3ecbd798376..0e604595dbcad1bf0acd5adc0b096453bb0737d7 100644 (file)
@@ -1,69 +1,69 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI=5
+EAPI=7
 
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
 
-inherit distutils-r1 eutils git-r3 readme.gentoo
+inherit distutils-r1 git-r3 eutils
 
-DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
-HOMEPAGE="http://ansible.com/"
-SRC_URI=""
-EGIT_REPO_URI="git://github.com/ansible/ansible.git"
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+EGIT_REPO_URI="https://github.com/ansible/ansible.git"
 EGIT_BRANCH="devel"
 
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS=""
-IUSE="test"
+IUSE="doc test"
+RESTRICT="test"
 
 RDEPEND="
-       dev-python/httplib2[${PYTHON_USEDEP}]
+       dev-python/paramiko[${PYTHON_USEDEP}]
        dev-python/jinja[${PYTHON_USEDEP}]
-       dev-python/keyczar[${PYTHON_USEDEP}]
-       >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
        dev-python/pyyaml[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/cryptography[${PYTHON_USEDEP}]
+       dev-python/httplib2[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/netaddr[${PYTHON_USEDEP}]
+       dev-python/pexpect[${PYTHON_USEDEP}]
        net-misc/sshpass
        virtual/ssh
 "
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+               >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+       )
        test? (
                ${RDEPEND}
-               dev-python/mock[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
+               >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
                dev-python/passlib[${PYTHON_USEDEP}]
+               dev-python/coverage[${PYTHON_USEDEP}]
+               dev-python/unittest2[${PYTHON_USEDEP}]
                dev-vcs/git
        )"
 
-python_test() {
-       nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+python_compile_all() {
+       if use doc; then
+               cd docs/docsite || die
+               export CPUS=4
+               emake -f Makefile.sphinx html
+       fi
 }
 
-python_compile_all() {
-       local _man
-       for _man in ansible{,-{galaxy,playbook,pull,vault}}; do
-               a2x -f manpage docs/man/man1/${_man}.1.asciidoc.in || die "Failed generating man page (${_man})"
-       done
+python_test() {
+       nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
 }
 
 python_install_all() {
-       EXAMPLES=( examples )
+       use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
        distutils-r1_python_install_all
 
-       doman docs/man/man1/*.1
-
-       newenvd "${FILESDIR}"/${PN}.env 95ansible
-}
-
-src_install() {
-       distutils-r1_src_install
-       readme.gentoo_create_doc
-}
-
-pkg_postinst() {
-       optfeature "Alternative ssh transport" dev-python/paramiko
+       dodoc -r examples
 }