Add remove option.
[gentoolkit.git] / README.dev
index 7a33d1cb25a3a45750935872d6dc4cc7fe19b31a..84f7cf3b51154a276af14e75f7a12c4e7ad3aa6b 100644 (file)
@@ -12,14 +12,28 @@ pylint --rcfile=pylintrc yourfile.py
 
 Creating a release:
 ===================
+Note: We are using VERSION="0.3.0" simply as an example.
+
 - Run Gentoolkit's test suite, make sure it passes:
+Note: requires dev-python/snakeoil
+
+Note: If running from the gentoolkit repository, please grab the eclean test file from:
+http://genscripts.googlecode.com/svn/trunk/gentoolkit/pym/gentoolkit/test/eclean/testdistfiles.tar.gz
+Please do not add/commit the test file to the gentoolkit repository
+
 ./setup.py test
+
 - Create a tag for the release
-- Set the version of the release:
-VERSION="0.3.0" ./setup set_version
-- Create a source distribution (you need to add VERSION here, too):
+svn copy svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/trunk/gentoolkit \
+         svn+ssh://<dev>@svn.gentoo.org/var/svnroot/gentoolkit/tags/gentoolkit-0.3.0 \
+        -m "Tagging the <VERSION> release of gentoolkit."
+svn update to pull the tag from subversion
+cd to the local tags/gentoolkit-0.3.0 directory
+
+- Create a source distribution (you need to add VERSION here):
 VERSION="0.3.0" ./setup.py sdist
-- Reset svn version to 'svn' (default):
-./setup.py set_version
+Transfer dist/gentoolkit-0.3.0.tar.gz to dev.gentoo.org:/space/distfiles-local
+
 - Clean up temporary files:
-./setup clean -a
+./setup.py clean -a
+