RepoConfigLoader: Fix indent
[portage.git] / Makefile
index 247c0546794b3ae759139375df0b69fc0f3b35f2..92ea195629bbf96583f1d42577aaed5fbc6eff70 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -27,13 +27,14 @@ INSMODE = 0644
 EXEMODE = 0755
 DIRMODE = 0755
 SYSCONFDIR_FILES = etc-update.conf dispatch-conf.conf
-PORTAGE_CONFDIR_FILES = make.globals
+PORTAGE_CONFDIR_FILES = make.conf.example make.globals repos.conf
 LOGROTATE_FILES = elog-save-summary
 BINDIR_FILES = ebuild egencache emerge emerge-webrsync \
        emirrordist portageq quickpkg repoman
 SBINDIR_FILES = archive-conf dispatch-conf emaint \
        env-update etc-update fixpackages regenworld
 DOCS = ChangeLog NEWS RELEASE-NOTES
+LINGUAS ?= $(shell cd "$(srcdir)/man" && find -mindepth 1 -type d)
 
 ifdef PYTHONPATH
        PYTHONPATH := $(srcdir)/pym:$(PYTHONPATH)
@@ -50,8 +51,6 @@ docbook:
 
 epydoc:
        set -e; \
-       # workaround for bug 282760 \
-       touch "$(srcdir)/pym/pysqlite2.py"; \
        env PYTHONPATH="$(PYTHONPATH)" epydoc \
                -o "$(WORKDIR)/epydoc" \
                --name $(PN) \
@@ -63,9 +62,7 @@ epydoc:
                -e s:^pym/:: \
                -e s:/:.:g \
                | sort); \
-       rm -f "$(srcdir)/pym/pysqlite2.py"* \
-               "$(WORKDIR)/epydoc/pysqlite2-"* \
-               "$(WORKDIR)/epydoc/api-objects.txt"; \
+       rm -f "$(WORKDIR)/epydoc/api-objects.txt"; \
 
 test:
        set -e; \
@@ -81,9 +78,6 @@ install:
        cd "$(srcdir)/cnf"; \
        install -m$(INSMODE) $(PORTAGE_CONFDIR_FILES) \
                "$(DESTDIR)$(portage_confdir)"; \
-       install -m$(INSMODE) "$(srcdir)/cnf/make.conf" \
-               "$(DESTDIR)$(portage_confdir)/make.conf.example"; \
-       \
        install -d -m$(DIRMODE) "$(DESTDIR)$(portage_setsdir)"; \
        cd "$(S)/cnf/sets"; \
        install -m$(INSMODE) *.conf "$(DESTDIR)$(portage_setsdir)"; \
@@ -184,15 +178,17 @@ install:
        cd "$(srcdir)"; \
        install -m $(INSMODE) $(DOCS) "$(DESTDIR)$(docdir)"; \
        \
-       for x in "" $$(cd "$(srcdir)/man" && find -type d) ; do \
+       for x in "" $(LINGUAS); do \
                for y in 1 5 ; do \
-                       cd "$(srcdir)/man/$$x"; \
-                       files=$$(echo *.$$y); \
-                       if [ -z "$$files" ] || [ "$$files" = "*.$$y" ]; then \
-                               continue; \
+                       if [ -d "$(srcdir)/man/$$x" ]; then \
+                               cd "$(srcdir)/man/$$x"; \
+                               files=$$(echo *.$$y); \
+                               if [ -z "$$files" ] || [ "$$files" = "*.$$y" ]; then \
+                                       continue; \
+                               fi; \
+                               install -d -m$(DIRMODE) "$(DESTDIR)$(mandir)/$$x/man$$y"; \
+                               install -m$(INSMODE) *.$$y "$(DESTDIR)$(mandir)/$$x/man$$y"; \
                        fi; \
-                       install -d -m$(DIRMODE) "$(DESTDIR)$(mandir)/$$x/man$$y"; \
-                       install -m$(INSMODE) *.$$y "$(DESTDIR)$(mandir)/$$x/man$$y"; \
                done; \
        done; \
        \
@@ -214,7 +210,6 @@ install:
 clean:
        set -e; \
        $(MAKE) -C "$(srcdir)/doc" clean; \
-       rm -rf "$(srcdir)/pym/pysqlite2.py"* \
-               "$(WORKDIR)/epydoc"; \
+       rm -rf "$(WORKDIR)/epydoc"; \
 
 .PHONY: all clean docbook epydoc install test