xfce-extra/xfce4-time-out-plugin: Revbump post dep change
[gentoo.git] / xfce-extra / xfce4-pulseaudio-plugin / xfce4-pulseaudio-plugin-0.4.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit xdg-utils
7
8 DESCRIPTION="A panel plug-in for PulseAudio volume control"
9 HOMEPAGE="https://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/"
10 SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 x86"
15 IUSE="debug keybinder libnotify wnck"
16
17 RDEPEND=">=dev-libs/glib-2.42.0:=
18         media-sound/pulseaudio:=
19         >=x11-libs/gtk+-3.20.0:3=
20         >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
21         >=xfce-base/libxfce4util-4.9.0:=
22         >=xfce-base/xfce4-panel-4.11.0:=
23         >=xfce-base/xfconf-4.6.0:=
24         keybinder? ( dev-libs/keybinder:3= )
25         libnotify? ( x11-libs/libnotify:= )
26         wnck? ( x11-libs/libwnck:3= )"
27 DEPEND="${RDEPEND}
28         dev-util/intltool
29         virtual/pkgconfig"
30
31 src_configure() {
32         local myconf=(
33                 $(use_enable keybinder)
34                 $(use_enable libnotify)
35                 $(use_enable wnck)
36         )
37
38         econf "${myconf[@]}"
39 }
40
41 src_install() {
42         default
43
44         find "${D}" -name '*.la' -delete || die
45 }
46
47 pkg_postinst() {
48         xdg_icon_cache_update
49
50         if ! has_version media-sound/pavucontrol; then
51                 elog "For the 'audio mixer...' shortcut to work, you need to install"
52                 elog "an external mixer application. Please either install:"
53                 elog
54                 elog "  media-sound/pavucontrol"
55                 elog
56                 elog "or specify another application to use in the 'Properties' dialog."
57         fi
58 }
59
60 pkg_postrm() {
61         xdg_icon_cache_update
62 }