xfce-extra/xfce4-embed-plugin: Inline mirror://xfce
[gentoo.git] / xfce-extra / xfce4-notifyd / xfce4-notifyd-0.4.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2-utils
7
8 DESCRIPTION="Notification daemon for the Xfce desktop environment"
9 HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-notifyd"
10 SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~arm64 x86"
15 IUSE=""
16
17 RDEPEND=">=dev-libs/glib-2.42:2=
18         >=x11-libs/gtk+-3.14:3=
19         >=x11-libs/libnotify-0.7:=
20         >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
21         >=xfce-base/libxfce4util-4.12:=
22         >=xfce-base/xfce4-panel-4.12:=
23         >=xfce-base/xfconf-4.10:="
24 DEPEND="${RDEPEND}
25         dev-util/gdbus-codegen
26         dev-util/intltool
27         sys-devel/gettext
28         virtual/pkgconfig"
29
30 DOCS=( AUTHORS NEWS README TODO )
31
32 pkg_postinst() {
33         gnome2_icon_cache_update
34 }
35
36 pkg_postrm() {
37         gnome2_icon_cache_update
38 }