xfce-extra/xfce4-notes-plugin: stable 1.8.1-r1 for ppc, bug #682952
[gentoo.git] / xfce-extra / xfce4-notes-plugin / xfce4-notes-plugin-1.8.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit versionator xfconf
6
7 DESCRIPTION="Xfce4 panel sticky notes plugin"
8 HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
9 SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
14 IUSE=""
15
16 RDEPEND=">=dev-libs/glib-2.24:2=
17         >=x11-libs/gtk+-2.20:2=
18         >=xfce-base/libxfce4ui-4.10:=
19         >=xfce-base/libxfce4util-4.10:=
20         >=xfce-base/xfce4-panel-4.10:=
21         >=xfce-base/xfconf-4.10:=
22         dev-libs/libunique:1="
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig
25         dev-util/intltool"
26
27 pkg_setup() {
28         DOCS=( AUTHORS ChangeLog NEWS README )
29 }