xfce-extra/xfce4-notes-plugin: stable 1.8.1-r1 for ppc, bug #682952
[gentoo.git] / xfce-extra / xfce4-notes-plugin / xfce4-notes-plugin-1.8.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit xdg-utils
7
8 DESCRIPTION="Xfce4 panel sticky notes plugin"
9 HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
10 SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
15 IUSE=""
16
17 RDEPEND=">=dev-libs/glib-2.24:2
18         >=x11-libs/gtk+-2.20:2
19         >=xfce-base/libxfce4ui-4.10:=
20         >=xfce-base/libxfce4util-4.10:=
21         >=xfce-base/xfce4-panel-4.10:=
22         >=xfce-base/xfconf-4.10:=
23         dev-libs/libunique:1="
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig
26         dev-util/intltool"
27
28 src_install() {
29         default
30         find "${D}" -name '*.la' -delete || die
31 }
32
33 pkg_postinst() {
34         xdg_icon_cache_update
35 }
36
37 pkg_postrm() {
38         xdg_icon_cache_update
39 }