dev-ruby/ruby-pango: add ruby-gnome 3.0.7
[gentoo.git] / xfce-extra / xfce4-hdaps / xfce4-hdaps-0.0.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit linux-info xfconf
7
8 DESCRIPTION="A plugin to indicate the status of the IBM Hard Drive Active Protection System"
9 HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.php"
10 SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.bz2"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="debug"
16
17 COMMON_DEPEND=">=x11-libs/gtk+-2.20:2
18         x11-libs/libX11
19         >=xfce-base/libxfce4ui-4.8
20         >=xfce-base/libxfce4util-4.8
21         >=xfce-base/xfce4-panel-4.8"
22 RDEPEND="${COMMON_DEPEND}
23         >=app-laptop/hdapsd-20090101
24         >=app-laptop/tp_smapi-0.39"
25 DEPEND="${COMMON_DEPEND}
26         dev-util/intltool
27         sys-devel/gettext
28         virtual/pkgconfig"
29
30 pkg_setup() {
31         XFCONF=(
32                 $(xfconf_use_debug)
33                 )
34
35         DOCS=( AUTHORS ChangeLog README TODO )
36
37         linux-info_pkg_setup
38
39         if kernel_is lt 2 6 28; then
40                 echo
41                 ewarn "Unsupported kernel detected. Upgrade to 2.6.28 or above."
42                 echo
43         fi
44 }