xfce-extra/xfce4-taskmanager: Bump to 1.2.3
[gentoo.git] / xfce-extra / xfce4-cpugraph-plugin / xfce4-cpugraph-plugin-1.1.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit xdg-utils
7
8 DESCRIPTION="A system load plug-in for the Xfce panel"
9 HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
10 SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
11
12 LICENSE="BSD-2 GPL-2+"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
15
16 RDEPEND=">=x11-libs/gtk+-3.22:3
17         >=xfce-base/libxfce4ui-4.12:=
18         >=xfce-base/xfce4-panel-4.12:="
19 DEPEND="${RDEPEND}
20         dev-util/intltool
21         sys-devel/gettext
22         virtual/pkgconfig"
23
24 src_install() {
25         default
26         find "${ED}" -name '*.la' -delete || die
27 }
28
29 pkg_postinst() {
30         xdg_icon_cache_update
31 }
32
33 pkg_postrm() {
34         xdg_icon_cache_update
35 }