dev-ruby/ruby-pango: add ruby-gnome 3.0.7
[gentoo.git] / xfce-extra / xfce4-clipman-plugin / xfce4-clipman-plugin-1.2.6.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit xfconf
7
8 DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
9 HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
10 SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
15 IUSE="debug qrcode"
16
17 RDEPEND=">=dev-libs/glib-2.18
18         dev-libs/libunique:1
19         >=x11-libs/gtk+-2.14:2
20         x11-libs/libXtst
21         >=xfce-base/exo-0.10
22         >=xfce-base/libxfce4ui-4.10
23         >=xfce-base/libxfce4util-4.10
24         >=xfce-base/xfce4-panel-4.10
25         >=xfce-base/xfconf-4.10
26         qrcode? ( >=media-gfx/qrencode-3.3.0 )"
27 DEPEND="${RDEPEND}
28         dev-util/intltool
29         sys-devel/gettext
30         virtual/pkgconfig
31         x11-proto/xproto"
32
33 pkg_setup() {
34         XFCONF=(
35                 --docdir="${EPREFIX}"/usr/share/doc/${PF}
36                 $(use_enable qrcode libqrencode)
37                 $(xfconf_use_debug)
38                 )
39
40         DOCS=( AUTHORS ChangeLog NEWS README )
41 }