x11-terms/alacritty: revbump 0.3.3, remove terminfo useflag
[gentoo.git] / xfce-base / xfdesktop / xfdesktop-4.13.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2-utils
7
8 DESCRIPTION="Desktop manager for the Xfce desktop environment"
9 HOMEPAGE="https://www.xfce.org/projects/"
10 SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
15 IUSE="debug libnotify +thunar"
16
17 RDEPEND=">=x11-libs/cairo-1.12:=
18         >=dev-libs/glib-2.42:=
19         >=x11-libs/gtk+-3.22:3=
20         >=x11-libs/libwnck-3.14:3=
21         x11-libs/libX11:=
22         >=xfce-base/exo-0.11:=
23         >=xfce-base/garcon-0.6:=
24         >=xfce-base/libxfce4ui-4.13:=
25         >=xfce-base/libxfce4util-4.13:=
26         >=xfce-base/xfconf-4.12.1:=
27         libnotify? ( >=x11-libs/libnotify-0.7:= )
28         thunar? (
29                 >=dev-libs/glib-2.38:=
30                 >=xfce-base/thunar-1.7:=
31                 )"
32 DEPEND="${RDEPEND}
33         dev-util/intltool
34         sys-devel/gettext
35         virtual/pkgconfig"
36
37 src_configure() {
38         local myconf=(
39                 $(use_enable thunar file-icons)
40                 $(use_enable thunar thunarx)
41                 $(use_enable libnotify notifications)
42         )
43
44         econf "${myconf[@]}"
45 }
46
47 pkg_postinst() {
48         gnome2_icon_cache_update
49 }
50
51 pkg_postrm() {
52         gnome2_icon_cache_update
53 }