dev-python/jaraco-text: keyworded 3.2.0 for ia64, bug #717946
[gentoo.git] / xfce-base / xfce4-settings / xfce4-settings-4.15.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit xdg-utils
6
7 DESCRIPTION="Configuration system for the Xfce desktop environment"
8 HOMEPAGE="https://www.xfce.org/projects/"
9 SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
14 IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
15
16 RDEPEND="
17         >=dev-libs/glib-2.24
18         media-libs/fontconfig
19         x11-libs/gtk+:3
20         x11-libs/libX11
21         >=x11-libs/libXcursor-1.1
22         >=x11-libs/libXi-1.3
23         >=x11-libs/libXrandr-1.2
24         >=xfce-base/garcon-0.2:=
25         >=xfce-base/exo-0.11:=
26         >=xfce-base/libxfce4ui-4.15.1:=
27         >=xfce-base/libxfce4util-4.12:=
28         >=xfce-base/xfconf-4.13:=
29         colord? ( x11-misc/colord:= )
30         libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
31         input_devices_libinput? ( x11-drivers/xf86-input-libinput )
32         libnotify? ( >=x11-libs/libnotify-0.7 )
33         upower? ( >=sys-power/upower-0.9.23 )
34         xklavier? ( >=x11-libs/libxklavier-5 )"
35 DEPEND="${RDEPEND}
36         dev-util/gdbus-codegen
37         dev-util/intltool
38         virtual/pkgconfig
39         sys-devel/gettext
40         x11-base/xorg-proto"
41
42 src_configure() {
43         local myconf=(
44                 $(use_enable upower upower-glib)
45                 $(use_enable input_devices_libinput xorg-libinput)
46                 $(use_enable libnotify)
47                 $(use_enable colord)
48                 $(use_enable xklavier libxklavier)
49                 $(use_enable libcanberra sound-settings)
50         )
51         econf "${myconf[@]}"
52 }
53
54 pkg_postinst() {
55         xdg_icon_cache_update
56 }
57
58 pkg_postrm() {
59         xdg_icon_cache_update
60 }