xfce-base/libxfce4ui: Bump to 4.13.4, add vala support
[gentoo.git] / xfce-base / libxfce4ui / libxfce4ui-4.13.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit xfconf
6
7 DESCRIPTION="Unified widget and session management libraries for Xfce"
8 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
9 SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
10
11 LICENSE="LGPL-2"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
14 IUSE="debug glade startup-notification"
15
16 RDEPEND=">=dev-libs/glib-2.30:2=
17         >=x11-libs/gtk+-2.24:2=
18         >=x11-libs/gtk+-3.2:3=
19         x11-libs/libX11:=
20         x11-libs/libICE:=
21         x11-libs/libSM:=
22         >=xfce-base/libxfce4util-4.12:=
23         >=xfce-base/xfconf-4.12:=
24         glade? ( dev-util/glade:3.10= )
25         startup-notification? ( x11-libs/startup-notification:= )
26         !xfce-base/xfce-utils"
27 DEPEND="${RDEPEND}
28         dev-lang/perl
29         dev-util/intltool
30         sys-devel/gettext
31         virtual/pkgconfig"
32
33 pkg_setup() {
34         XFCONF=(
35                 $(use_enable startup-notification)
36                 $(xfconf_use_debug)
37                 # does not build without GTK+3, #585684
38                 --enable-gtk3
39                 # requires deprecated glade:3 (gladeui-1.0), bug #551296
40                 --disable-gladeui
41                 # this one's for :3.10
42                 $(use_enable glade gladeui2)
43                 --with-vendor-info=Gentoo
44                 )
45
46         [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
47
48         DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
49 }