dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-wm / windowlab / windowlab-1.40-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="small and simple window manager of novel design"
9 HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
10 SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~mips ppc x86"
15 IUSE="truetype"
16
17 RDEPEND="truetype? ( x11-libs/libXft )
18         x11-libs/libXext"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig
21         x11-base/xorg-proto"
22
23 PATCHES=( "${FILESDIR}/${PN}-1.34-fixed-font.patch"
24           "${FILESDIR}/${P}-gentoo.diff" )
25
26 pkg_setup() {
27         if use truetype ; then
28                 export DEFINES=-DXFT
29                 export EXTRA_INC=$(pkg-config --cflags xft)
30                 export EXTRA_LIBS=$(pkg-config --libs xft)
31         fi
32         tc-export CC
33 }
34
35 src_install() {
36         default
37
38         exeinto /etc/X11/Sessions
39         cat <<- EOF > "${T}"/${PN}
40                 #!/bin/sh
41                 exec /usr/bin/${PN}
42         EOF
43         doexe "${T}"/${PN}
44 }
45
46 pkg_postinst() {
47         elog "${PN}'s menu config file has been changed from"
48         elog "/etc/X11/${PN}/menurc to /etc/X11/${PN}/${PN}.menurc"
49 }