x11-wm/sawfish: Fix building with CFLAGS=-fno-common
[gentoo.git] / x11-wm / stumpwm-contrib / stumpwm-contrib-20180128.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit common-lisp-3
7
8 DESCRIPTION="Extension Modules for StumpWM"
9 HOMEPAGE="https://github.com/stumpwm/stumpwm-contrib/"
10
11 if [[ ${PV} == 9999* ]] ; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/stumpwm/stumpwm-contrib/"
14 else
15         SRC_URI="mirror://gentoo/${P}.tar.bz2"
16         KEYWORDS="~amd64 ~x86"
17 fi
18
19 LICENSE="GPL-2 GPL-3 BSD-2"
20 SLOT="0"
21 IUSE=""
22
23 RDEPEND=">=x11-wm/stumpwm-1.0.0"
24
25 CONTRIBCATEGORIES="media minor-mode modeline util"
26
27 src_install() {
28         common-lisp-install-sources -t all ${CONTRIBCATEGORIES}
29         dobin util/stumpish/stumpish
30         dobin util/pinentry/stumpwm-pinentry
31         dodoc README.org
32 }