x11-misc/xtoolwait: Port to EAPI 7
[gentoo.git] / x11-wm / marco / marco-1.22.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MATE2_LA_PUNT="yes"
7
8 inherit mate
9
10 if [[ ${PV} != 9999 ]]; then
11         KEYWORDS="amd64 ~arm ~arm64 x86"
12 fi
13
14 DESCRIPTION="MATE default window manager"
15 LICENSE="GPL-2"
16 SLOT="0"
17
18 IUSE="startup-notification test xinerama"
19 RESTRICT="!test? ( test )"
20
21 COMMON_DEPEND="
22         dev-libs/atk
23         >=dev-libs/glib-2.50:2
24         >=gnome-base/libgtop-2:2=
25         media-libs/libcanberra[gtk3]
26         x11-libs/cairo
27         >=x11-libs/pango-1.2[X]
28         x11-libs/gdk-pixbuf:2
29         >=x11-libs/gtk+-3.22:3
30         x11-libs/libICE
31         x11-libs/libSM
32         x11-libs/libX11
33         >=x11-libs/libXcomposite-0.3
34         x11-libs/libXcursor
35         x11-libs/libXdamage
36         x11-libs/libXext
37         x11-libs/libXfixes
38         x11-libs/libXpresent
39         x11-libs/libXrandr
40         x11-libs/libXrender
41         >=x11-libs/startup-notification-0.7
42         virtual/libintl
43         xinerama? ( x11-libs/libXinerama )
44         !!x11-wm/mate-window-manager"
45
46 RDEPEND="${COMMON_DEPEND}
47         gnome-extra/zenity
48         >=mate-base/mate-desktop-1.20.0"
49
50 DEPEND="${COMMON_DEPEND}
51         app-text/yelp-tools
52         >=dev-util/intltool-0.34.90
53         sys-devel/gettext:*
54         virtual/pkgconfig:*
55         x11-base/xorg-proto
56         test? ( app-text/docbook-xml-dtd:4.5 )
57         xinerama? ( x11-base/xorg-proto )"
58
59 src_configure() {
60         mate_src_configure \
61                 --enable-compositor \
62                 --enable-render \
63                 --enable-shape \
64                 --enable-sm \
65                 --enable-xsync \
66                 $(use_enable startup-notification) \
67                 $(use_enable xinerama)
68 }
69
70 src_install() {
71         mate_src_install
72         dodoc {,doc/}*.txt
73 }