x11-wm/awesome: Fix dependency issue for Gentoo/FreeBSD.
[gentoo.git] / x11-wm / marco / marco-1.16.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MATE2_LA_PUNT="yes"
7
8 inherit mate
9
10 if [[ ${PV} != 9999 ]]; then
11         KEYWORDS="~amd64 ~arm ~x86"
12 fi
13
14 DESCRIPTION="MATE default window manager"
15 LICENSE="GPL-2"
16 SLOT="0"
17
18 IUSE="gtk3 startup-notification test xinerama"
19
20 COMMON_DEPEND="
21         dev-libs/atk:0
22         >=dev-libs/glib-2.32.10:2
23         >=gnome-base/libgtop-2:2=
24         x11-libs/cairo:0
25         >=x11-libs/pango-1.2:0[X]
26         x11-libs/gdk-pixbuf:2
27         x11-libs/libICE:0
28         x11-libs/libSM:0
29         x11-libs/libX11:0
30         >=x11-libs/libXcomposite-0.3:0
31         x11-libs/libXcursor:0
32         x11-libs/libXdamage:0
33         x11-libs/libXext:0
34         x11-libs/libXfixes:0
35         x11-libs/libXrandr:0
36         x11-libs/libXrender:0
37         >=x11-libs/startup-notification-0.7:0
38         virtual/libintl:0
39         !gtk3? (
40                 media-libs/libcanberra:0[gtk]
41                 >=x11-libs/gtk+-2.24:2
42         )
43         gtk3? (
44                 media-libs/libcanberra:0[gtk3]
45                 >=x11-libs/gtk+-3.0:3
46         )
47         xinerama? ( x11-libs/libXinerama:0 )
48         !!x11-wm/mate-window-manager"
49
50 RDEPEND="${COMMON_DEPEND}
51         gnome-extra/zenity:0
52         >=mate-base/mate-desktop-1.9[gtk3(-)=]
53 "
54
55 DEPEND="${COMMON_DEPEND}
56         app-text/yelp-tools:0
57         >=dev-util/intltool-0.34.90:*
58         sys-devel/gettext:*
59         virtual/pkgconfig:*
60         x11-proto/xextproto:0
61         x11-proto/xproto:0
62         test? ( app-text/docbook-xml-dtd:4.5 )
63         xinerama? ( x11-proto/xineramaproto:0 )"
64
65 src_configure() {
66         mate_src_configure \
67                 --enable-compositor \
68                 --enable-render \
69                 --enable-shape \
70                 --enable-sm \
71                 --enable-xsync \
72                 --with-gtk=$(usex gtk3 3.0 2.0) \
73                 $(use_enable startup-notification) \
74                 $(use_enable xinerama)
75 }
76
77 src_install() {
78         mate_src_install
79         dodoc {,doc/}*.txt
80 }