x11-wm/fluxbox: revbump to fix sandbox issues
[gentoo.git] / x11-wm / goomwwm / goomwwm-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit git-r3 toolchain-funcs
6
7 DESCRIPTION="Get out of my way, Window Manager!"
8 HOMEPAGE="https://github.com/seanpringle/goomwwm"
9 EGIT_REPO_URI="${HOMEPAGE}"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS=""
14 IUSE="debug"
15
16 RDEPEND="
17         x11-libs/libXft
18         x11-libs/libX11
19         x11-libs/libXinerama
20 "
21 DEPEND="
22         ${RDEPEND}
23         virtual/pkgconfig
24         x11-proto/xineramaproto
25         x11-proto/xproto
26 "
27
28 src_prepare() {
29         default
30         sed -i -e 's|$(LDADD) $(LDFLAGS)|$(LDFLAGS) $(LDADD)|g' Makefile || die
31 }
32
33 src_configure() {
34         use debug && append-cflags -DDEBUG
35 }
36
37 src_compile() {
38         emake CC=$(tc-getCC) proto normal
39 }
40
41 src_install() {
42         dobin ${PN}
43         doman ${PN}.1
44 }