x11-wm/lumina: fix dependencies, install icons and session file
[gentoo.git] / x11-wm / goomwwm / goomwwm-1.0.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="Get out of my way, Window Manager!"
8 HOMEPAGE="http://aerosuidae.net/goomwwm/"
9 SRC_URI="http://aerosuidae.net/${PN}/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug"
15
16 RDEPEND="
17         x11-libs/libXft
18         x11-libs/libX11
19         x11-libs/libXinerama
20 "
21 DEPEND="
22         ${RDEPEND}
23         virtual/pkgconfig
24         x11-base/xorg-proto
25 "
26
27 src_prepare() {
28         sed -i -e 's|$(LDADD) $(LDFLAGS)|$(LDFLAGS) $(LDADD)|g' Makefile || die
29 }
30
31 src_configure() {
32         use debug && append-cflags -DDEBUG
33 }
34
35 src_compile() {
36         emake CC=$(tc-getCC) proto normal
37 }
38
39 src_install() {
40         dobin ${PN}
41         doman ${PN}.1
42 }