Merge game-action/minetest: Version bump to 0.4.13
[gentoo.git] / x11-wm / enlightenment / enlightenment-0.17.9999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 MY_P=${P/_/-}
8
9 if [[ ${PV} == *9999 ]] ; then
10         EGIT_SUB_PROJECT="core"
11         EGIT_URI_APPEND="${PN}"
12 else
13         SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.xz"
14         EKEY_STATE="snap"
15 fi
16
17 inherit enlightenment
18
19 DESCRIPTION="Enlightenment DR17 window manager"
20
21 LICENSE="BSD-2"
22 KEYWORDS="~amd64 ~arm ~x86"
23 SLOT="0.17/${PV%%_*}"
24
25 # The @ is just an anchor to expand from
26 __EVRY_MODS=""
27 __CONF_MODS="
28         +@applications +@comp +@dialogs +@display
29         +@interaction +@intl +@menus
30         +@paths +@performance +@randr +@shelves +@theme +@wallpaper2
31         +@window-manipulation +@window-remembers"
32 __NORM_MODS="
33         @access +@appmenu +@backlight +@bluez4 +@battery +@clock
34         +@connman +@contact +@cpufreq +@everything +@fileman
35         +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2 +@mixer +@msgbus
36         +@music-control +@notification +@pager +@quickaccess +@shot
37         +@start +@syscon +@systray +@tasks +@teamwork +@temperature +@tiling
38         +@winlist +@wizard @wl-desktop-shell @wl-screenshot +@xkbswitch"
39 IUSE_E_MODULES="
40         ${__CONF_MODS//@/enlightenment_modules_conf-}
41         ${__NORM_MODS//@/enlightenment_modules_}"
42
43 IUSE="pam spell static-libs systemd +udev ukit wayland ${IUSE_E_MODULES}"
44
45 RDEPEND="
46         pam? ( sys-libs/pam )
47         systemd? ( sys-apps/systemd )
48         wayland? (
49                 dev-libs/efl[wayland]
50                 >=dev-libs/wayland-1.2.0
51                 >=x11-libs/pixman-0.31.1
52                 >=x11-libs/libxkbcommon-0.3.1
53         )
54         >=dev-libs/efl-${PV}[X]
55         >=media-libs/elementary-${PV}
56         x11-libs/xcb-util-keysyms"
57 DEPEND="${RDEPEND}"
58
59 S=${WORKDIR}/${MY_P}
60
61 src_prepare() {
62         epatch "${FILESDIR}"/quickstart.diff
63         enlightenment_src_prepare
64 }
65
66 src_configure() {
67         E_ECONF=(
68                 --disable-install-sysactions
69                 $(use_enable doc)
70                 --disable-device-hal
71                 $(use_enable nls)
72                 $(use_enable pam)
73                 $(use_enable systemd)
74                 --enable-device-udev
75                 $(use_enable udev mount-eeze)
76                 $(use_enable ukit mount-udisks)
77                 $(use_enable wayland wayland-clients)
78         )
79         local u c
80         for u in ${IUSE_E_MODULES} ; do
81                 u=${u#+}
82                 c=${u#enlightenment_modules_}
83                 E_ECONF+=( $(use_enable ${u} ${c}) )
84         done
85         enlightenment_src_configure
86 }
87
88 src_install() {
89         enlightenment_src_install
90         insinto /etc/enlightenment
91         newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
92 }