x11-themes/geany-themes: Drop old
[gentoo.git] / x11-themes / tango-icon-theme-extras / tango-icon-theme-extras-0.1.0-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5 inherit autotools eutils gnome2-utils
6
7 DESCRIPTION="Tango icons for iPod Digital Audio Player devices and the Dell Pocket DJ DAP"
8 HOMEPAGE="http://tango.freedesktop.org"
9 SRC_URI="http://tango.freedesktop.org/releases/${P}.tar.gz"
10
11 LICENSE="CC-BY-SA-2.5"
12 SLOT="0"
13 KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
14 IUSE="png"
15
16 RDEPEND=">=x11-themes/tango-icon-theme-0.8.90"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig
19         >=gnome-base/librsvg-2.34
20         virtual/imagemagick-tools[png?]
21         >=x11-misc/icon-naming-utils-0.8.90"
22
23 RESTRICT="binchecks strip"
24
25 DOCS="AUTHORS ChangeLog NEWS README"
26
27 src_prepare() {
28         epatch "${FILESDIR}"/${P}-graphicsmagick.patch
29         epatch "${FILESDIR}"/${P}-MKDIR_P.patch
30         sed -i -e '/svgconvert_prog/s:rsvg:&-convert:' configure{,.ac} || die #413183
31         eautoreconf
32 }
33
34 src_configure() {
35         econf \
36                 $(use_enable png png-creation) \
37                 $(use_enable png icon-framing)
38 }
39
40 pkg_preinst() { gnome2_icon_savelist; }
41 pkg_postinst() { gnome2_icon_cache_update; }
42 pkg_postrm() { gnome2_icon_cache_update; }