dev-qt/qtprintsupport: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-themes / smplayer-skins / smplayer-skins-15.2.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit qmake-utils
7
8 DESCRIPTION="Skins for SMPlayer"
9 HOMEPAGE="https://www.smplayer.info/"
10 SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
11
12 LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 GPL-2 LGPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
15 IUSE=""
16
17 DEPEND="dev-qt/qtcore:5"
18 RDEPEND="media-video/smplayer"
19
20 src_prepare() {
21         default
22
23         sed -i -e 's/make/$(MAKE)/' Makefile || die
24         sed -i -e "s|rcc -binary|$(qt5_get_bindir)/&|" themes/Makefile || die
25 }
26
27 src_install() {
28         rm themes/Makefile || die
29         insinto /usr/share/smplayer
30         doins -r themes
31         dodoc Changelog README.txt
32 }