Use https by default
[gentoo.git] / x11-themes / larry-backgrounds / larry-backgrounds-20110822.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="3"
6
7 DESCRIPTION="Wallpapers featuring Gentoo mascot Larry the cow"
8 HOMEPAGE="https://www.gentoo.org/main/en/graphics.xml#wallpapers"
9 web_home='https://www.gentoo.org/images/backgrounds'
10 SRC_URI="
11         ${web_home}/gentoo-abducted-800x600.png
12         ${web_home}/gentoo-abducted-1024x768.png
13         ${web_home}/gentoo-abducted-1152x864.png
14         ${web_home}/gentoo-abducted-1280x1024.png
15         ${web_home}/gentoo-abducted-1600x1200.png
16         ${web_home}/gentoo-abducted-1680x1050.png
17         ${web_home}/larry-cave-cow-1024x768.jpg
18         ${web_home}/larry-cave-cow-1152x864.jpg
19         ${web_home}/larry-cave-cow-1280x1024.jpg
20         ${web_home}/larry-cave-cow-1600x1200.jpg
21         ${web_home}/gentoo-larry-bg-4:3.svg
22         ${web_home}/gentoo-larry-bg-5:4.svg
23         ${web_home}/gentoo-larry-bg-8:5.svg
24         ${web_home}/gentoo-larry-bg-16:9.svg
25         ${web_home}/gentoo-larry-bg-800x600.png
26         ${web_home}/gentoo-larry-bg-1024x768.png
27         ${web_home}/gentoo-larry-bg-1152x864.png
28         ${web_home}/gentoo-larry-bg-1280x720.png
29         ${web_home}/gentoo-larry-bg-1280x800.png
30         ${web_home}/gentoo-larry-bg-1280x960.png
31         ${web_home}/gentoo-larry-bg-1280x1024.png
32         ${web_home}/gentoo-larry-bg-1366x768.png
33         ${web_home}/gentoo-larry-bg-1440x900.png
34         ${web_home}/gentoo-larry-bg-1600x900.png
35         ${web_home}/gentoo-larry-bg-1600x1200.png
36         ${web_home}/gentoo-larry-bg-1680x1050.png
37         ${web_home}/gentoo-larry-bg-1920x1080.png
38         ${web_home}/gentoo-larry-bg-1920x1200.png
39 "
40
41 LICENSE="CC-BY-SA-2.5 CC-BY-NC-SA-2.5"
42 SLOT="0"
43 KEYWORDS="amd64 x86"
44 IUSE=""
45
46 RESTRICT="mirror"  # TODO make a tarball, instead?
47
48 src_unpack() { :; }
49
50 src_install() {
51         local backdrops='/usr/share/xfce4/backdrops'
52         local share_home='backgrounds/larry-the-cow'
53
54         insinto /usr/share/${share_home}/
55         ( cd "${DISTDIR}" && doins ${A} ) || die
56
57         # Integrate with KDE 4
58         dosym ../${share_home} /usr/share/wallpapers/larry-the-cow || die
59
60         # Integrate with XFCE 4
61         dodir ${backdrops}/ || die
62         dosym ../../${share_home}/gentoo-abducted-1600x1200.png ${backdrops}/gentoo-abducted-4:3.png || die
63         dosym ../../${share_home}/gentoo-abducted-1280x1024.png ${backdrops}/gentoo-abducted-5:4.png || die
64         dosym ../../${share_home}/gentoo-abducted-1680x1050.png ${backdrops}/gentoo-abducted-8:5.png || die
65         dosym ../../${share_home}/larry-cave-cow-1600x1200.jpg ${backdrops}/larry-cave-cow-4:3.jpg || die
66         dosym ../../${share_home}/larry-cave-cow-1280x1024.jpg ${backdrops}/larry-cave-cow-5:4.jpg || die
67         for ratio in 4:3 5:4 8:5 16:9 ; do
68                 dosym ../../${share_home}/gentoo-larry-bg-${ratio}.svg ${backdrops}/gentoo-larry-bg-${ratio}.svg || die
69         done
70 }