x11-themes/elementary-xfce-icon-theme: Bump to 0.15
[gentoo.git] / x11-themes / iceicons / iceicons-0.10.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="IceWM Icons is a set of XPM 16x16, 32x32, and 48x48 XPM and PNG icons for IceWM"
7 HOMEPAGE="http://sandbox.cz/~covex/icewm/iceicons/"
8 SRC_URI="http://sandbox.cz/~covex/icewm/iceicons/${PN}-default-${PV}.tar.gz"
9 LICENSE="LGPL-2.1"
10
11 SLOT="0"
12 KEYWORDS="amd64 ~ppc sparc x86"
13 IUSE=""
14
15 RDEPEND=">=x11-wm/icewm-1.2.6"
16 DEPEND="${RDEPEND}"
17
18 S="${WORKDIR}"
19 ICEICONSDIR="/usr/share/icewm/icons/iceicons"
20
21 src_install() {
22         dodir "${ICEICONSDIR}"
23         cp -pPR icons/* "${D}"/"${ICEICONSDIR}" || die
24         chown -R root:0 "${D}"/"${ICEICONSDIR}" || die
25         chmod -R o-w "${D}"/"${ICEICONSDIR}" || die
26
27         dodoc CHANGELOG README TODO winoptions
28 }
29
30 pkg_postinst() {
31         einfo
32         einfo "To use new IceWm icons, add following"
33         einfo "into your IceWm preference file:"
34         einfo "IconPath=\"${ICEICONSDIR}:${ICEICONSDIR}/menuitems\""
35         einfo
36 }
37
38 pkg_postrm() {
39         einfo
40         einfo "Update your IceWm preference."
41         einfo
42 }