dev-qt/qtprintsupport: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-themes / gnome-colors-themes / gnome-colors-themes-5.5.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2-utils
6
7 DESCRIPTION="Some gnome-colors iconsets including a Gentoo one"
8 HOMEPAGE="https://code.google.com/p/gnome-colors/"
9
10 SRC_URI="https://gnome-colors.googlecode.com/files/gnome-colors-${PV}.tar.gz
11         https://dev.gentoo.org/~pacho/gnome-gentoo-${PV}.tar.gz"
12
13 LICENSE="GPL-2 public-domain"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 RDEPEND="x11-themes/gnome-colors-common"
19 DEPEND=""
20
21 RESTRICT="binchecks strip"
22
23 S="${WORKDIR}"
24
25 src_compile() {
26         einfo "Nothing to compile"
27 }
28
29 src_install() {
30         dodir /usr/share/icons
31         insinto /usr/share/icons
32         for i in gnome*; do
33                 if [ "$i" != "gnome-colors-common" ]; then
34                         doins -r "${i}"
35                 fi
36         done
37         einstalldocs
38 }
39
40 pkg_preinst() {
41         gnome2_icon_savelist
42 }
43
44 pkg_postinst() {
45         gnome2_icon_cache_update
46 }
47
48 pkg_postrm() {
49         gnome2_icon_cache_update
50 }