1e71574ad87d288a707da71b48abe09a3673f220
[gentoo.git] / x11-themes / gentoo10-backgrounds / gentoo10-backgrounds-20110309.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Gentoo - 10 Years Compiling Background Artwork"
7 HOMEPAGE="https://www.gentoo.org/inside-gentoo/artwork/"
8
9 SRC_URI="https://dev.gentoo.org/~flameeyes/${P}.tar.xz"
10
11 LICENSE="CC-BY-SA-3.0"
12 KEYWORDS="amd64 ~mips x86"
13 IUSE=""
14
15 RDEPEND=""
16 DEPEND="app-arch/xz-utils"
17
18 S="${WORKDIR}/${PN}"
19
20 SLOT="0"
21
22 src_prepare() {
23         sed -i -e "s:/usr/:${EPREFIX}/usr/:" *.xml || die
24 }
25
26 src_compile() { :; }
27 src_test() { :; }
28
29 src_install() {
30
31         insinto /usr/share/backgrounds/gentoo10
32         doins -r {purple,blue,red}.xml netbook standard wide wider || die
33
34         insinto /usr/share/gnome-background-properties
35         doins desktop-*.xml || die
36
37         # KDE wallpapers
38         for color in purple blue red; do
39                 insinto /usr/share/wallpapers/Gentoo10_${color}
40                 newins gentoo10-${color}-metadata.desktop metadata.desktop
41
42                 dodir /usr/share/wallpapers/Gentoo10_${color}/contents/images
43                 for file in */*/${color}.jpg; do
44                         dosym ../../../../backgrounds/gentoo10/"${file}" /usr/share/wallpapers/Gentoo10_${color}/contents/images/"$(basename "$(dirname "${file}")")".jpg
45                 done
46         done
47 }