Use https by default
[gentoo.git] / x11-themes / gentoo10-backgrounds / gentoo10-backgrounds-20110309.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="Gentoo - 10 Years Compiling Background Artwork"
8 HOMEPAGE="https://www.gentoo.org/proj/en/pr/releases/10.0/graphics.xml"
9
10 SRC_URI="https://dev.gentoo.org/~flameeyes/${P}.tar.xz"
11
12 LICENSE="CC-BY-SA-3.0"
13 KEYWORDS="amd64 ~mips x86"
14 IUSE=""
15
16 RDEPEND=""
17 DEPEND="app-arch/xz-utils"
18
19 S="${WORKDIR}/${PN}"
20
21 SLOT="0"
22
23 src_prepare() {
24         sed -i -e "s:/usr/:${EPREFIX}/usr/:" *.xml || die
25 }
26
27 src_compile() { :; }
28 src_test() { :; }
29
30 src_install() {
31
32         insinto /usr/share/backgrounds/gentoo10
33         doins -r {purple,blue,red}.xml netbook standard wide wider || die
34
35         insinto /usr/share/gnome-background-properties
36         doins desktop-*.xml || die
37
38         # KDE wallpapers
39         for color in purple blue red; do
40                 insinto /usr/share/wallpapers/Gentoo10_${color}
41                 newins gentoo10-${color}-metadata.desktop metadata.desktop
42
43                 dodir /usr/share/wallpapers/Gentoo10_${color}/contents/images
44                 for file in */*/${color}.jpg; do
45                         dosym ../../../../backgrounds/gentoo10/"${file}" /usr/share/wallpapers/Gentoo10_${color}/contents/images/"$(basename "$(dirname "${file}")")".jpg
46                 done
47         done
48 }