x11-themes/human-icon-theme: update homepage
[gentoo.git] / x11-themes / gentoo-xcursors / gentoo-xcursors-0.3.1.ebuild
1 # Copyright 2005-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="A high quality set of animated mouse cursors"
7 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
8 SRC_URI="mirror://gentoo/${PN/xcursors/cursors}-tad-${PV}.tar.bz2"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 sparc x86"
13 IUSE=""
14
15 RDEPEND=""
16 DEPEND="${RDEPEND}"
17
18 S="${WORKDIR}/cursors"
19
20 src_install() {
21         insinto /usr/share/cursors/xorg-x11
22         doins -r *
23 }
24
25 pkg_postinst() {
26         einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
27         einfo "and add the following line (for example):"
28         einfo "Xcursor.theme: gentoo"
29         einfo ""
30         einfo "You can change the size by adding a line like:"
31         einfo "Xcursor.size: 48"
32         einfo ""
33         einfo "Also, to globally use this set of mouse cursors edit the file:"
34         einfo "   /usr/local/share/cursors/xorg-x11/default/index.theme"
35         einfo "and change the line:"
36         einfo "    Inherits=[current setting]"
37         einfo "to (for example)"
38         einfo "    Inherits=gentoo"
39         einfo ""
40         einfo "Note this will be overruled by a user's ~/.Xdefaults file."
41         einfo ""
42         ewarn "If you experience flickering, try setting the following line in"
43         ewarn ""
44         ewarn "the Device section of your xorg.conf file:"
45         ewarn "    Option  \"HWCursor\"  \"false\""
46         einfo ""
47         einfo "The three sets installed are gentoo, gentoo-silver and gentoo-blue."
48 }