Use https by default
[gentoo.git] / x11-themes / gartoon / gartoon-0.5-r2.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=2
6
7 DESCRIPTION="Gartoon SVG icon theme"
8 HOMEPAGE="https://www.gentoo.org"
9 SRC_URI="mirror://gentoo/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 IUSE=""
13 KEYWORDS="amd64 ~ppc sparc ~x86"
14 SLOT="0"
15
16 RESTRICT="binchecks strip"
17
18 S=${WORKDIR}/${PN}
19
20 pkg_setup() {
21         mydest="/usr/share/icons/${PN}"
22 }
23
24 src_prepare() {
25         sed -e "s:\(^pixmap_path\) \(\".*\"$\):\1 \"${mydest}/scalable/stock\":" \
26                 -i scalable/stock/iconrc || die "sed failed"
27 }
28
29 src_install() {
30         insinto ${mydest}
31         doins index.theme scalable/stock/iconrc
32
33         dodoc AUTHORS README scalable/stock/changelog_mula.txt
34
35         for dir in apps devices emblems filesystems mimetypes stock; do
36                 cd "${S}"/scalable/${dir}
37                 insinto ${mydest}/scalable/${dir}
38                 for svg in *svg; do
39                         doins ${svg}
40                 done
41         done
42
43         dosym gnome-lockscreen.svg ${mydest}/scalable/apps/xfce-system-lock.svg
44         dosym control-center2.svg ${mydest}/scalable/apps/xfce-system-settings.svg
45         dosym gnome-logout.svg ${mydest}/scalable/apps/xfce-system-exit.svg
46         dosym mozilla-firefox.svg ${mydest}/scalable/apps/firefox-icon.svg
47         dosym gnome-globe.svg ${mydest}/scalable/apps/firefox-icon-unbranded.svg
48 }