dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-themes / fvwm-crystal / fvwm-crystal-3.4.1-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7 inherit eutils readme.gentoo-r1 python-r1 user
8
9 DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
10 HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
16 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
17
18 case ${PV} in
19 *9999)
20         inherit subversion
21         ESVN_REPO_URI="svn://svn.code.sf.net/p/fvwm-crystal/code"
22         SRC_URI=""
23         KEYWORDS=""
24         S="${WORKDIR}/${PN}"
25         src_unpack() {
26                 subversion_src_unpack
27         };;
28 esac
29
30 RDEPEND="${PYTHON_DEPS}
31         >=x11-wm/fvwm-2.5.26[png]
32         virtual/imagemagick-tools
33         || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
34         || ( x11-misc/hsetroot media-gfx/feh )
35         sys-apps/sed
36         sys-devel/bc
37         virtual/awk
38         x11-apps/xwd
39         media-sound/alsa-utils"
40
41 DISABLE_AUTOFORMATTING="true"
42 DOC_CONTENTS="After installation, execute the following commands:
43         $ cp -r "${EROOT}"usr/share/doc/"${PF}"/addons/Xresources ~/.Xresources
44         $ cp -r "${EROOT}"usr/share/doc/"${PF}"/addons/Xsession ~/.xinitrc
45
46 Many applications can extend functionality of fvwm-crystal.
47 They are listed in "${EROOT}"usr/share/doc/"${PF}"/INSTALL.*
48
49 To be able to use the exit menu, each user using ${PN}
50 must be in the group fvwm-crystal.
51 You can do that as root with:
52         $ useradd -G fvwm-crystal <user_name>
53 and log out and in again.
54 "
55
56 pkg_setup() {
57         enewgroup fvwm-crystal
58 }
59
60 src_install() {
61         emake \
62                 DESTDIR="${ED}" \
63                 docdir="${EPREFIX}/usr/share/doc/${PF}" \
64                 prefix="${EPREFIX}/usr" \
65                 install
66         # GNU License is globally in the portage tree
67         rm -vf "${ED}/usr/share/doc/${PF}"/LICENSE
68
69         python_replicate_script \
70                 "${ED}/usr/bin/${PN}".{apps,wallpaper} \
71                 "${ED}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
72         readme.gentoo_create_doc
73 }
74
75 pkg_postinst() {
76         readme.gentoo_print_elog
77         elog "Many applications can extend functionality of fvwm-crystal."
78         elog "They are listed in ${EROOT}usr/share/doc/${PF}/INSTALL.bz2"
79         elog "Popular supported softwares are:"
80         elog "- x11-misc/xdg-user-dirs (the gtk USE is not needed) to"
81         elog "  get localized XDG user directories support"
82         elog "- sys-power/pm-utils for hibernate/resume support"
83         elog "- media-sound/jack-audio-connection-kit for a professional sound server"
84         elog "- several media players"
85 }