sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / x11-themes / fvwm-crystal / fvwm-crystal-3.2.5-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 PYTHON_COMPAT=( python2_7 )
7 inherit eutils python-r1
8
9 DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
10 HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
16
17 RDEPEND="${PYTHON_DEPS}
18         >=x11-wm/fvwm-2.6.5[png]
19         virtual/imagemagick-tools
20         || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
21         || ( x11-misc/hsetroot media-gfx/feh )
22         sys-apps/sed
23         sys-devel/bc
24         virtual/awk
25         x11-apps/xwd"
26
27 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
28
29 src_install() {
30         emake \
31                 DESTDIR="${D}" \
32                 docdir="/usr/share/doc/${PF}" \
33                 prefix="/usr" \
34                 install
35
36         python_replicate_script \
37                 "${D}/usr/bin/${PN}".{apps,wallpaper} \
38                 "${D}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
39 }
40
41 pkg_postinst() {
42         einfo
43         einfo "After installation, execute following commands:"
44         einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xresources ~/.Xresources"
45         einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xsession ~/.xinitrc"
46         einfo
47         einfo "Many applications can extend functionality of fvwm-crystal."
48         einfo "They are listed in ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
49         einfo
50         einfo "Some icons fixes was committed recently."
51         einfo "To archive the same fixes on your private icon files,"
52         einfo "please read ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
53         einfo "This will fix the libpng warnings at stderr."
54         einfo
55         einfo "The color themes was updated to Fvwm InfoStore."
56         einfo "To know how to update your custom color themes, please run"
57         einfo " ${ROOT}usr/share/${PN}/addons/convert_colorsets"
58         einfo ""
59 }