dev-python/towncrier: keyworded 19.2.0 for ia64, bug #700918
[gentoo.git] / x11-themes / faenza-icon-theme / faenza-icon-theme-1.3.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit gnome2-utils
6
7 MY_P=${PN}_${PV}
8
9 DESCRIPTION="A scalable icon theme called Faenza"
10 HOMEPAGE="http://tiheum.deviantart.com/art/Faenza-Icons-173323228"
11 # Use Ubuntu repo which has a proper faenza-icon-theme tarball
12 #SRC_URI="https://faenza-icon-theme.googlecode.com/files/${PN}_${PV}.tar.gz"
13 SRC_URI="https://ppa.launchpad.net/tiheum/equinox/ubuntu/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
14
15 RESTRICT="binchecks strip"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="amd64 ~arm x86"
20 IUSE="minimal"
21
22 RDEPEND="!minimal? ( x11-themes/adwaita-icon-theme )
23         x11-themes/hicolor-icon-theme"
24
25 S=${WORKDIR}/${PN}-${PV%.*}
26
27 src_prepare() {
28         local res x
29         for x in Faenza Faenza-Dark; do
30                 for res in 22 24 32 48 64 96; do
31                         cp "${x}"/places/${res}/start-here-gentoo.png \
32                                 "${x}"/places/${res}/start-here.png || die
33                 done
34                 cp "${x}"/places/scalable/start-here-gentoo.svg \
35                         "${x}"/places/scalable/start-here.svg || die
36         done
37 }
38
39 src_install() {
40         insinto /usr/share/icons
41         doins -r Faenza{,-Ambiance,-Dark,-Darker,-Darkest,-Radiance}
42
43         # TODO: Install to directories where the apps can find them
44         # insinto ${somewhere}
45         # doins -r emesene dockmanager rhythmbox
46 }
47
48 pkg_preinst() { gnome2_icon_savelist; }
49 pkg_postinst() { gnome2_icon_cache_update; }
50 pkg_postrm() { gnome2_icon_cache_update; }