dev-python/towncrier: keyworded 19.2.0 for ia64, bug #700918
[gentoo.git] / x11-themes / arc-icon-theme / arc-icon-theme-20161122.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools gnome2-utils
7
8 DESCRIPTION="Vertex icon theme"
9 HOMEPAGE="https://github.com/horst3180/arc-icon-theme"
10 SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 IUSE=""
15 KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
16
17 # Require adwaita until moka is packaged
18 RDEPEND="
19         x11-themes/adwaita-icon-theme
20 "
21 DEPEND=""
22
23 # This ebuild does not install any binaries
24 RESTRICT="binchecks strip"
25
26 src_prepare() {
27         default
28         eautoreconf
29 }
30
31 pkg_preinst() {
32         gnome2_icon_savelist
33 }
34
35 pkg_postinst() {
36         gnome2_icon_cache_update
37 }
38
39 pkg_postrm() {
40         gnome2_icon_cache_update
41 }