x11-themes/QGnomePlatform: Bump to 0.6.1
[gentoo.git] / x11-themes / QGnomePlatform / QGnomePlatform-0.6.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit qmake-utils
6
7 DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
8 HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
9 SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
10
11 KEYWORDS="~amd64 ~ppc64 ~x86"
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         >=dev-qt/qtwidgets-5.6:5=
18         dev-qt/qtwayland:5=
19         dev-qt/qtx11extras:5=
20         x11-libs/gtk+:3[X]
21 "
22 DEPEND="${RDEPEND}"
23 BDEPEND="${RDEPEND}"
24
25 src_configure() {
26         eqmake5
27 }
28
29 src_install() {
30         INSTALL_ROOT="${D}" default
31 }