x11-terms/mlterm: drop old
[gentoo.git] / x11-terms / yeahconsole / yeahconsole-0.3.4-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit toolchain-funcs
6
7 DESCRIPTION="yeahconsole turns an xterm or rxvt-unicode into a game-like console"
8 HOMEPAGE="http://phrat.de/yeahtools.html"
9 SRC_URI="http://phrat.de/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 hppa x86"
14 RDEPEND="
15         x11-libs/libX11
16 "
17 DEPEND="
18         ${RDEPEND}
19         x11-base/xorg-proto
20 "
21 PATCHES=(
22         "${FILESDIR}"/${P}-make.patch
23 )
24
25 src_compile() {
26         tc-export CC
27         emake
28 }
29
30 src_install() {
31         dodir /usr/bin
32         emake PREFIX="${D}"/usr install
33         dodoc README
34 }
35
36 pkg_postinst() {
37         elog "Do not forget to emerge an xterm compatible terminal emulator"
38         elog "(perhaps x11-terms/xterm or x11-terms/rxvt-unicode), or"
39         elog "${PN} will not work ;-)."
40 }